Passport Debit card Feature failure

Incident Report for Passport

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 12:36 UTC

Update

Issue has been resolved
Posted Sep 09, 2026 - 12:36 UTC

Update

Some cardholders may be experiencing intermittent issues with debit card transactions, card management and related account activity.
We have traced this to an internal processing error that caused a subset of transaction requests to be rejected before completion.
We are monitoring the issue closely and will post an update as soon as service is fully restored.
Posted Sep 09, 2026 - 09:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 07:29 UTC

Investigating

We are investigating reports of Feature failures. We are actively researching and will provide more information shortly.
Posted Sep 09, 2026 - 07:06 UTC
This incident affected: API, Management Portal, and Passport.